Single-day time series API requests returning inaccurate error message
Incident Report for Open Exchange Rates
Resolved
We have resolved this issue, and as of 4:00pm UTC all Time Series API requests are functioning as expected.

Please don't hesitate to contact us with any questions or concerns.
Posted almost 2 years ago. Dec 20, 2016 - 21:34 UTC
Investigating
We are investigating an issue affecting some clients using our Time Series (/time-series.json) API endpoint.

The issue affects requests to `/time-series.json` which specify the same `start` and `end` dates (i.e. requests for a single day of data) and do not specify a subset of currencies via the `symbols` parameter. These requests incorrectly return a `400` error.

All other API endpoints, and all other normal requests to the Time Series API (i.e. in all cases where a client requests multiple days of data or requests a specific subset of currencies via the `symbols` parameter), are unaffected.

We will update this page as soon as we have resolved or have further information.

Please contact us at support@openexchangerates.org with any questions or concerns.
Posted almost 2 years ago. Dec 20, 2016 - 09:52 UTC