We are investigating a service outage last night
Incident Report for Open Exchange Rates
Resolved
This incident was caused by an upstream issue at our web host, manifesting in delayed responses (30s+) and timeouts for a large number of our clients. It's our responsibility to safeguard the availability of our service to you; we've already deployed changes to our API platform to prevent a recurrence and our monitoring has not detected any further issue since May 4th.

Thanks for your patience while we scale up to be able to serve you better. Please contact support@openexchangerates.org with any questions.
Posted almost 2 years ago. May 16, 2016 - 10:24 UTC
Investigating
We experienced an unplanned service outage on both our primary API and website last night. We're looking into the cause right now and will update as soon as we know more. Sincere apologies for any inconvenience caused.
Posted almost 2 years ago. May 04, 2016 - 08:27 UTC